Function keys not working on AIX (smitty) when using Putty

Working on a AIX deployment for the moment.

A very usefull tool on AIX for configuring a lot of stuff on the system is smitty

Capture

Issue is that on smitty you have to use the keyboards function keys to navigate. These don’t work.

There is a simple solution for this.

Go to you Putty preferences and alter your “Terminal – Keyboard” settings for the “function keys and keypad” to “Xterm R6”

Make sure to save this setting to your server connection.

2014-05-08 15_04_40-PuTTY Configuration

Advertisements

About Wannes Rams

I'm a IBM Collaboration software consultant. I am specialized in the architecture and technical lead of enterprise implementations. I started of as a Lotus Domino specialist certified up to Domino 8, but moved on to IBM Connections, Lotus Sametime and Lotus Quickr. I also have experience with WebSphere Administration and WebSphere Portal deployments. I am also IBM Champion for ICS Specialties: Lotus Domino Lotus Sametime Lotus Quickr IBM Connections WebSphere Portal administration WebSphere Application server administration Cisco Firewall administration Tivoli Directory Integrator Social Business
This entry was posted in AIX, Technical and tagged , , , . Bookmark the permalink.

2 Responses to Function keys not working on AIX (smitty) when using Putty

  1. Joe Hayes says:

    Excellent! Thank you for posting this.

  2. kris@gmail.com says:

    Thanks

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s